Local Wallet Stuck on Block 514548 How do I drop Peers in Qbundle?



  • One of my wallets got stuck 14 hours ago. When I restarted it it was ok. Either fault with the wallet or someone messing with pool wallets.



  • instaled the latest qbundel,,now i cant start my blagominer!!


  • admin

    @bytheseaster In windows defender settings exclude the QBundle directory, then download the miner again



  • @haitch A big Thanks to My GURU haitch!!!!



  • @haitch Have you every seen this? It happens only on one of my wallets. It happens once a day.

    0_1533110014885_crash.PNG

    I stop it restart it then its ok till the next crash lol



  • @tross
    I'm barely able to read this screencap as it is VERY small and I am rather old,
    but something pops up from memory:

    If your database was created with the defaults, the (systemwide) defaults may not be set to the vallues burst needs. I had this problem on a standalone mariadb installation on FreeBSD, and the setup hints contain

    $ echo "CREATE DATABASE burstwallet; 
          CREATE USER 'brs_user'@'localhost' IDENTIFIED BY 'yourpassword';
          GRANT ALL PRIVILEGES ON burstwallet.* TO 'brs_user'@'localhost';" | mysql -uroot
    $ mysql -uroot burstwallet < init-mysql.sql
    

    where the create statement above should contain the charset and collation explicitly;

    CREATE DATABASE burstwallet CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ;
    

    In order to find out the charset/collation of your database:

    $ echo "SELECT SCHEMA_NAME 'burstwallet', default_character_set_name 'charset', DEFAULT_COLLATION_NAME 'collation' FROM information_schema.SCHEMATA ;  " | mysql -uroot
    burstwallet	charset	collation
    burstwallet	utf8mb4	utf8mb4_unicode_ci
    $
    

    If you get "latin1" or just the bare "utf8" in the charset column, you can quickly change that (depends on your machine and the speed of the underlying storage for the database) -
    stop the wallet (!) and export/drop/create/import the database:

    $ mysqldump burstwallet >/somewhere/dump.sql
    $ echo "DROP DATABASE burstwallet ;" | mysql -uroot
    $ echo "CREATE DATABASE burstwallet CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ; " | mysql -uroot
    $ mysql -uroot burstwallet </somewhere/dump.sql
    

    After that restart the wallet and see whether the daily error goes away.
    Alternatively, just import the dump into a new database (without touching the db burstwallet), alter the brs.properties to use this secondary. If the error goes away, throw away the primary and keep the secondary, or vice versa.



  • @tross

    TLDR; find out if your database has the correct charset/collation:

    $ echo "SELECT SCHEMA_NAME 'burstwallet', default_character_set_name 'charset', DEFAULT_COLLATION_NAME 'collation' FROM information_schema.SCHEMATA ;  " | mysql -uroot
    burstwallet	charset	collation
    burstwallet	utf8mb4	utf8mb4_unicode_ci
    $
    

    If you get "latin1" or just the bare "utf8" in the charset column, you have found a problem.



  • Funny thing is I have 2 online wallet one one vps and one on vm. They are the same meaning created them same way. he vps wallet crashes I see about making image bigger.



  • @tross The VPS/VM "machines" may very well have different default settings for mariadb - or are they using the exact same codebase at the time of installation ? I guess not..



  • I deactivated uPnP maybe will help.

    Wallet on vps crashed 2 times both times between 2am and 3am which sounds fishy. I have had attacks in the past
    and all was at that time.