AMD GPU not detedcted Miner will not start





  • @blago, yes would be happy to, but where is it? I do not see it in the Burst folder(s)

    thanks,





  • @energy Hi, Im on windows and do not have access to visual studio to build this, would this be what I'm missing, gpu plot generator? I am currently using turbo plotter and it uses the gpu to generate plots just fine, I am just unable to gpu mine, so this the missing piece for me?



  • @frntman00 reinstall amd driver?

    as I see from the log, ( Sorry it took me so long ), it's because it is picking up your Intel OpenCL driver!



  • @hidevin Thanks for checking back, I suspected that it was picking up the integrated gpu, I just cant figure out why its not picking up the amd card, I have removed and did a clean reinstalled multiple drivers using the ddu tool but nothing. I have just installing the amd catalyst OpenCL only, as well as the blockchain computing driver, and the current radeon gaming driver, most all of the drivers show up as openCL in gpuz if that even matters.

    On another note I have downloaded and installed the free community version of VS however it requires a reboot and Im plotting, so I guess I will hae to provide the devices.txt file for the others later



  • @frntman00 glad that it is working, sorry for not noticing earlier, a bit slow lol



  • Well, I have now built a different os, java , and as well as latest NVIDA drivers and jminer still is not seeing my installed GPU. So, my main question @luxe, is the use of gpuPlotGenerator necessary to jminer to function? Do I need to install a different driver other than the amd or nvidia driver? While researching is I keep coming across referenced to the readme.md which just talks about how to compile gpuPlotGenerator which is very confusing as I really do not see the need OCLChecker is detecting something, just not what I need it to and this is the disconnect. I will not be using this machine for plotting, just mining only. Blago miner works fine but for performance reasons I would much rather use a gpu miner if I can get it to detect an installed gpu

    C:\Users\Frntmn\AppData\Roaming\burstcoin-jminer-master>java -jar -d64 -XX:+UseG1GC burstcoin-jminer-0.4.11-SNAPSHOT.jar
    11:34:47.659 [main] INFO burstcoin.jminer.JMinerApplication - Starting the engines ... please wait!
    2018-03-07 11:34:49.409  INFO 6228 --- [           main] b.jminer.core.checker.util.OCLChecker    : -------------------------------------------------------
    2018-03-07 11:34:49.409  INFO 6228 --- [           main] b.jminer.core.checker.util.OCLChecker    : List of system openCL platforms and devices (* = used for mining)
    2018-03-07 11:34:49.409  INFO 6228 --- [           main] b.jminer.core.checker.util.OCLChecker    :
    2018-03-07 11:34:49.409  INFO 6228 --- [           main] b.jminer.core.checker.util.OCLChecker    :  * PLATFORM-[0] Intel(R) OpenCL - (OpenCL 2.1)
    2018-03-07 11:34:49.409  INFO 6228 --- [           main] b.jminer.core.checker.util.OCLChecker    :  *   DEVICE-[0] Intel(R) Core(TM) i3-7100 CPU @ 3.90GHz (17GB) - Intel(R) Corporation (OpenCL 2.1 (Build 2) | '6.8.0.2')
    2018-03-07 11:34:49.409  INFO 6228 --- [           main] b.jminer.core.checker.util.OCLChecker    :  *          [0] work group size: '8192', computing units: '4', available 'true'
    2018-03-07 11:34:50.183  INFO 6228 --- [           main] b.jminer.core.checker.util.OCLChecker    :
    2018-03-07 11:34:50.197  INFO 6228 --- [           main] b.jminer.core.checker.util.OCLChecker    : (*) openCL context successfully started! (platformId: 0, deviceId: 0)
    2018-03-07 11:34:50.204  INFO 6228 --- [           main] b.jminer.core.checker.util.OCLChecker    : -------------------------------------------------------
    2018-03-07 11:34:51.117  INFO 6228 --- [           main] burstcoin.jminer.JMinerCommandLine       : -------------------------------------------------------
    2018-03-07 11:34:51.117  INFO 6228 --- [           main] burstcoin.jminer.JMinerCommandLine       :                             Burstcoin (BURST)
    2018-03-07 11:34:51.124  INFO 6228 --- [           main] burstcoin.jminer.JMinerCommandLine       :             __         __   GPU assisted PoC-Miner
    2018-03-07 11:34:51.124  INFO 6228 --- [           main] burstcoin.jminer.JMinerCommandLine       :            |__| _____ |__| ____   ___________
    2018-03-07 11:34:51.124  INFO 6228 --- [           main] burstcoin.jminer.JMinerCommandLine       :    version |  |/     \|  |/    \_/ __ \_  __ \
    2018-03-07 11:34:51.124  INFO 6228 --- [           main] burstcoin.jminer.JMinerCommandLine       :     0.4.11 |  |  Y Y  \  |   |  \  ___/|  | \/
    2018-03-07 11:34:51.124  INFO 6228 --- [           main] burstcoin.jminer.JMinerCommandLine       :        /\__|  |__|_|  /__|___|  /\___  >__|
    2018-03-07 11:34:51.124  INFO 6228 --- [           main] burstcoin.jminer.JMinerCommandLine       :        \______|     \/        \/     \/
    2018-03-07 11:34:51.124  INFO 6228 --- [           main] burstcoin.jminer.JMinerCommandLine       :       mining engine: BURST-LUXE-RED2-G6JW-H4HG5
    2018-03-07 11:34:51.124  INFO 6228 --- [           main] burstcoin.jminer.JMinerCommandLine       :      openCL checker: BURST-QHCJ-9HB5-PTGC-5Q8J9
    2018-03-07 11:34:51.579  INFO 6228 --- [    roundPool-1] burstcoin.jminer.JMinerCommandLine       : -------------------------------------------------------
    2018-03-07 11:34:51.582  INFO 6228 --- [    roundPool-1] burstcoin.jminer.JMinerCommandLine       : START block '466007', scoopNumber '2820', capacity '8000 GB'
    2018-03-07 11:34:51.582  INFO 6228 --- [    roundPool-1] burstcoin.jminer.JMinerCommandLine       :       targetDeadline '7776000', baseTarget '68287', genSig '46658e..'
    Exception in thread "readerPool-1" org.jocl.CLException: CL_OUT_OF_RESOURCES
    


  • some gpu cards won't function unless monitor is plugged in and in some cases dual gpu must be enabled in PC BIOS. I have had motherboards that will disable built in gpu completely for slot graphics.



  • Just to update, after a couple of clean installs, eventually the gpu got picked up. never figured out root cause as to why it didn't detect the AMD OpenCL drivers just glad it eventually did.