GPU plot generator v4.1.1 (Win/Linux)

  • @vadirthedark I think you should fix the numbers in your devices.txt

  • @ccminer New #'s

    0 0 512 128 8192 (devices.txt)
    _0_19700000_50000 (gpu generate)

    It is working!! Here is one of the last lines:

    0.02% (3584/19700000 remaining nonces), 926.90 nonces/minutes, ETA: 2w 0d 18h 9m

    How do these #'s compare? Do you know if adjustments can be made while plotting is going on?
    Thanks for all your help - could not have made it without your expert help!

  • @vadirthedark
    I don't think you can adjust while plotting! But you can mine during plotting!
    You are welcome!!
    Other folks helped me a lot and I'm gald I could do the same for you 😉

  • @luxe I set up the plotter on Linux. I have started plotting at ~14,000 nonces per minute. I have 2 Tesla m2050. my parameters are 0_200000_20000. This is the device ID :

    Id: 0
    Type: GPU
    Name: Tesla M2050
    Vendor: NVIDIA Corporation
    Version: OpenCL 1.1 CUDA
    Driver version: 367.57
    Max clock frequency: 1147MHz
    Max compute units: 14
    Global memory size: 2GB 574MB 192KB
    Max memory allocation size: 655MB 560KB
    Max work group size: 1024
    Local memory size: 48KB
    Max work-item sizes: (1024, 1024, 64)

    I set up the device.txt as follows : 0 0 2048 256 8192

    Do you know which parameters to use to increase plotting speeds ?

  • admin

    @CoinBuster If drive write speed is the bottleneck, you could try to plot multiple drives at once. But sry i do not know what parameters best for the compute units.

  • @CoinBuster, interested in what distro you are using and plotter you used?

  • @vadirthedark I am using ubuntu 14.04 and GPU plot generator v4.0.3 (Win/Linux)

  • @CoinBuster Thanks for the info. I am using Ubuntu 16.04. Could you tell me what Nvidia driver you are using?

  • @vadirthedark You have to download the right pack from Nvidia for your specific GPU.

    Depends on the drivers you want to install, some of them support 16.04. The driver I have downloaded do support 16.04. I installed pyopencl on my system.

  • @CoinBuster, Would you tell me the advantages you see for installing pyopencl?
    My GPU (GEforce 750TI) has similar specs. as your GPU. Did you install any additional
    repos. (i.e- Cuda, etc.) as help for plotting/mining?
    I am interested in system details for Linux based setups (successful and not). I did succeed onces
    with a very slow setup which took 5 days to plot only to stop when it hit what seems to the 5TB
    drive capacity which was derived from inaccurate input.
    Thanks again for any help you can give.

  • I get an error when trying to run the GPU plotting software.

    Loading platforms...
    Loading devices...
    Loading devices configurations...
    Initializing generation devices...

    [ERROR] Unable to open the source file

    Anyone know what file the error is referring to?

  •         Bump

  • [email protected]:/home/tate/gpuPlotGenerator-bin-linux-x64-4.0.2# ./gpuPlotGenerator listDevices 0
    ./gpuPlotGenerator: /usr/local/cuda-8.0/targets/x86_64-linux/lib/ no version information available (required by ./gpuPlotGenerator)
    GPU plot generator v4.0.2
    Author:   Cryo
    Bitcoin:  138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst:    BURST-YA29-QCEW-QXC3-BKXDL
    [ERROR][-1001][CL_UNKNOWN] Unable to retrieve the OpenCL platforms number
    [email protected]:/home/tate/gpuPlotGenerator-bin-linux-x64-4.0.2# 

  • @Tate-A Okay, Installed the latest Drivers and OpenCL. Now I get this.

    [email protected]:/home/tate/gpuPlotGenerator-bin-linux-x64-4.0.2# ./gpuPlotGenerator listDevices 0
    Inconsistency detected by dl-version.c: 224: _dl_check_map_versions: Assertion `needed != NULL' failed!
    [email protected]:/home/tate/gpuPlotGenerator-bin-linux-x64-4.0.2# 

  • @ccminer said in GPU plot generator v4.0.3 (Win/Linux):

    @vadirthedark I finally got my new r9 380 4gb and I installed it!
    So now I start to face your same problem to GPU plotting my hdd.
    did you finally have been able to use the script on ubuntu?

    Hello everyone. I decided to give this GPU plotting method a try. Once I got through the initial stages of prepping my system I recall there being a question of whether gpuPlotGenerator 4.0.3 supported CUDA or not. I ran the software not knowing either way but it just stopped.

    Before I go ahead and troubleshoot can someone clarify this for me please?


  • Hi,

    With what settings are we able to create a very optimized plots?
    1 GPU and 16GB of ram

  • Hi, just checking out this plotter as I found out my integrated GPU will work with the plotter/miners for Burst.

    I ran the setup to configure the GPU and the recommended values were not powers of 2:


    I put in the recommended values and the program appeared to store different values, specifically the 19 was stored as a 8:


    Is this normal?

  • @rds,



    @haitch, @daWallet, @luxe, @ccminer ?

  • admin

    @rds Not seen that before - I'd manually set it to a power of two - either down to 4096 or up to 8192

  • admin

    @rds This setup is just creating the devices.txt i guess ... you can always edit that by hand, too. But i can not tell you why the 19 was not saved but 8 instead (seams to be a cpu? very low work group size) ... if this is important to you, you could try contact dev via github.