GPU plot generator v4.1.1 (Win/Linux)



  • @KeenHero 980ti is still a decent card, why wouldn't you be able to plot with it?



  • I use my R9 270x for ploting so your 980ti should be golden πŸ˜›



  • idont know i get error -5 everytime cant load kernel



  • [ERROR][-5][CL_OUT_OF_RESOURCES] Error in step2 kernel launch



  • @KeenHero Try lowering the last number in your devices.txt file.



  • recomended settings are "1 0 6144 768 8192" is this correct for the 980ti?



  • @KeenHero If they are the values setted by the GPUplotter setup yes, of course they are the recommended settings, but your gpu seems to run out of resources (maybe because it has to compute all your os and other programs graphics): a solution could be lowering the hashesNumber (the last number, values must be between 1 and 8192, higher number=better performaces, check the readme file)...



  • @vadirthedark I suggest you to write here to get more effective help about your GPU plotter issue πŸ˜‰



  • ccminer,
    I tried the 'gpuPlotGenerator-bin-linux-x64-4.0.3' first, without success. Have done the first 4 steps listed below:

    Install the build-essential
    g++ packets
    Install OpenCL (available in the manufacturer SDKs)
    install the opencl headers ([apt-get install opencl-headers] on Ubuntu)

    The reminder is where I am in trouble. I do not understand this:

    Modify the [PLATFORM] variable to one of [32] or [64] depending on the target platform. Modify the [OPENCL_INCLUDE] and [OPENCL_LIB] variables of the Makefile to the correct path. Example:

    OPENCL_INCLUDE = /opt/AMDAPPSDK-2.9-1/include
    OPENCL_LIB = /opt/AMDAPPSDK-2.9-1/lib/x86_64

    Are the 'platform variables' listed and in which file should I look? Same question for 'OPenCL_...'.
    Thanks for any information you can give.



  • I hope that @luxe xould help @vadirthedark with this issue that interest me as well πŸ™‚



  • Okay - from Readme file,

    "Modify the [PLATFORM] variable to one of [32] or [64] depending on the target platform. Modify the [OPENCL_INCLUDE] and [OPENCL_LIB] variables of the Makefile to the correct path."

    "OPENCL_INCLUDE = /opt/AMDAPPSDK-2.9-1/include"
    "OPENCL_LIB = /opt/AMDAPPSDK-2.9-1/lib/x86_64"

    I constructed a 'Makefile' from: https://github.com/bhamon/gpuPlotGenerator/blob/master/Makefile
    and made modifications as listed above. While looking at the OPENCL_ variables I went to 'opt' to see if 'AMDAPPSDK..' existed, it does not - looked in Package Manager in Ubuntu to see if packet is listed, it is not. I will try to install AMDAPPSDK... in /opt.

    First ? - Is it ok to use the 'Makefile'?
    Second ? - Is the /opt the one in root? Not sure how to set this up to get correct path from 'OPENCL_'.

    Thanks for any help available.



  • @vadirthedark Try to open an issue to github, the author of the script reply, at least he replied to me


  • admin

    Sry, i just used the win build ... never tried to compile on linux.



  • Hi, the gpu plotter gives me problems in direct mode at crashes 0.70 or 0.80%, in buffer mode do not. but slow more than it is. because it happens?



  • Have found a script to assist 'gpuPlotGenerator' on github (gp-assistant-cli.sh). When I run the script I get:

    df: β€˜/media/imbota/burst’: No such file or directory
    ./gp-assistant-cli.sh: line 72: [: -gt: unary operator expected
    ERROR, you don't have sufficient space left in your system.

    The first line indicates the script is looking for a file or dir. I have set to plot to 1 plot for entire 5TB drive (burst). Can someone explain my mistake and how to set plotting for entire drive?

    Thanks



  • @vadirthedark I finally got my new r9 380 4gb and I installed it!
    So now I start to face your same problem to GPU plotting my hdd.
    did you finally have been able to use the script on ubuntu?



  • @ccminer, I started over from a new install-deleted files and downloaded .gz. After all the problems I was having, one seemed to arise from the gpu. My Nvidia card has several options of driver versions I could use. If you don't get the correct driver you will have problems. Another problem was the Makefile. I'm still having problems generating that because there isn't one in the download.
    Looks like you have a good gpu. Let me know how you are doing as you go along.
    This is a learning experience so I spend a lot of time reading from forums trying to get to where I want to go.



  • @ccminer
    Used nano to get Makefile and revised OPENCL_. However, when I ran make dist, got error. Seems make requires an options function (make [options] [target] ). Author left out this information.
    Any ideas" Thanks



  • @vadirthedark

    Finally I have been able to use the gpu plotter on my ubuntu 16.10 desktop computer.
    Later I'll write a post about my experience and how to do step by step in order to use help other linux/ubuntu users like us!
    with my card I can plot 5 tb in like 24 hours with a stagger sixe of 20 gb, I can't complain.
    About what you wrote you can edit the makefile just by opening it with gedit, no need to use the nano function from terminal, but also no need to compile the scrypt because the author issued already compiled version.


  • admin

    @ccminer Thanks, i followed the discussion on github ... https://github.com/bhamon/gpuPlotGenerator/issues/14