GPU plot generator v4.1.1 (Win/Linux)



  • @vaxman the 3tb is currently writing 51-71mb/s and plotter is going at 14k nounces the previous attempt the plotter had locked up doing nothing for 8 hours I sat here played with the settings until I got the plotter to run as fast as I think it can.
    The 3tb has 1 hour left then it will do the 4tb and lastly the 1tb
    3072 640 4096 is what I'm running atm
    4096,8192,1024,2048 all work as the first number but the rates drop to between 4000-9000 n/min especially when you run the 8192 I think much of the issue plotting on this machine stems from the ram it has if it had more ram or more vram my numbers would be better.
    For the second number 128-768 work a 280x has 2048 stream processors so technically that should work as well but nothing over 768 worked for me.
    The third number I wanted the plotter to report more responsively so I reduced it by half I read here that it doesn't effect plotting speed very much and can be set to 4 or up to 8192.

    and the 3tb is done average 14333 n/min took 10 hours was done in gpu direct mode


  • admin

    @Darkbane said in GPU plot generator v4.1.1 (Win/Linux):

    I can't wait to try out plotting two files at once, is there a command line option to create files in a series rather than parallel, or is it best to just make a batch file to launch each command line in succession, not sure I want to commit to such large files in case something goes wrong, now that I think about it, maybe I want to make smaller 256GB files rather than 1TB files... paranoia has begun...

    Batch file would be the solution, for me i had no crash at all, plotting multiple files over a week, but sure it depends on how stable you system is in general.

    there is no realistic performance difference as far as Burstcoin is concerned between smaller and larger plots right? as far as I have read so far a plot is a plot is a plot, since you won't get "better" deadlines due to file size, just overall volume of plots is the way to have more "lottery tickets" as you guys say...

    There is a performance difference, best is one big plotfile for one drive, but i would say 4-8 smaller files per drive may also be ok. But with 32x256GB on 8TB drive it will start getting slower while mining.
    For every file the drive has to re-position the read head, what may take a few ms. The idea of a optimized plotfile is, that the drive does not have to re-position head at all, with lot off small optimized files you go against that idea. But however it does not effect the deadline, just the time you may need to be able to commit it.



  • Hi guys,

    Bit of weirdness with this, maybe the latest update fixed it?

    Have an Nvidia Titan X, and using 0 1 4096 128 10 as the device settings.

    The plot being set as _3814592_64

    The first 99% will complete as fast as the drive can write, (Samsung EVO 960 NVMe M.2 1TB) but the last 1% drops down to, Kb/sec. Considering this drive can read/write at 2000/2000Mb/s just wondered what this massive drop in performance is down to at the end?

    Thankyou.



  • So downloaded the latest version, and no different, it writes a massive amount of data very quickly, then, bam, slows down writing the nonces at 4332/minute direct mode on a 2000/2000Mb drive.

    The CPU can write at 4x that, so I have no idea why the performance on this floors out so hard?



  • @XenForoSlavik having the same problem, performance drops and it's not constant @cryo



  • @HiDevin Quite, I have 2 titans now plotting at 70-80k nonces per minute in buffer mode, and the drive is laughing at the "pathetic" 300-400Mb/s write rate, yes, the drive is able to write faster than 2 graphics cards can give it data... so maybe im misunderstanding how the direct mode works, but something is quite drastically wrong when a CPU plotter can do it quicker.


  • admin

    @XenForoSlavik You're writing 3,815,592 values, in chunks of 64 values at a time, so around 59,000 blocks of scoops. When you start mining that,the miner will go seek to the first set of nonces, and read those 64, then seek to the 2nd set of nonces and read them, then seek to the 3rd set of nonces and read them ....... Disk seeks are computationally incredibly bad. Your cpu that can do billions of computations per second, is stuck waiting while the disk drive head moves, and more data can be read. Seek times are measured in milliseconds, to us that incredibly fast, to a CPU it's an eternity, and with your method of plotting, there are almost 60,000 seeks to mine a single plot.



  • @haitch At the moment I am simply trying to work out how to get the GPU writer to write out at a decent rate in direct mode. However, I can not work out why it will write out 99% of the plot at full speed, then on the last 1% it slows down to an absolute crawl.

    I updated to the latest build, and even with the pre-alocated space, it seems incapable of writing faster than 5k nonces a minute in direct mode. At first I suspected the hard drives, but after grabbing this M.2 drive to rule that out today, I can only guess theres an issue with the write out logic of the gpu writer, unless you have suggestions on other configs?

    Device settings: 0 1 4096 512 1024
    Drive size: 1,000,068,808,704 bytes


  • admin

    @XenForoSlavik If you're basically stopping plotting towards the end of your plot, you've set the number of nonces to high.

    The miner will write multiples of your stagger, up to the value of your number of nonces. But if number of nonces is not a multiple of the stagger, the plotter will round up and try to plot 101% of your hard disk.

    To calculate the correct number of nonces to use in your plot: floor((disk size in bytes / 262144) div <stagger>) * stagger



  • @haitch To test this, I created a 200Gb plot on the drive: 819200_8192

    This was the result:

    0_1498608947440_2017-06-28 01_13_31-C__Windows_system32_cmd.exe.png

    Now, did the same with Xplotter:

    0_1498609247780_2017-06-28 01_20_16-Burst.png


  • admin

    @XenForoSlavik I see a plotter plotting - am I missing something ?



  • @haitch said in GPU plot generator v4.1.1 (Win/Linux):

    @XenForoSlavik I see a plotter plotting - am I missing something ?

    Yes, the appalling speed. The first one is the GPU plotter... the second is Xplotter.

    Unless a GPU (Titan 😵 writing in direct mode at 1/3 the speed of a cpu is expected? When in buffer mode it can write at 35-40k.


  • admin

    @XenForoSlavik When writing in direct mode, gpuplotgenerator prior to the latest version goes through two stages - first it builds the file to hold the plot - depending on the drive size, this can be a day or more. Once built it then starts filling it in with plotted nonces. During Phase 1 your plotting rate will drop to miserable values, then during phase 2 it'll keep increasing.

    However, @cryo has released a new version of gpuplotgenaerator, that when run as admin totally skips the slow build the file phase. Kill you plot and grab the new version and restart.



  • I'm seeing some odd memory usage in Win 7 with 4.1.1 in direct mode (as admin) and was wondering if there was something I can do about it. First, plotting on a 3-core/6 thread xeon with 16 gb ram, rx 460.
    Devices: 0 0 8192 32 4
    Plotting 30482432 (8tb) nonces at 8192 stagger, at 17.5k nonces/min.
    Disk is writing at about 60% max speed.

    When I start it up not as administrator, memory use is as expected. When I start it up as administrator, memory use goes through the roof with all free ram being used, and windows gobbling up about 30 gigs of ram+swap. Within the first 15 min, I get a couple catalyst-titled windows with nothing in the window, which normally indicate memory problems, but nothing comes of it. It then slowly unwinds part of the memory and swap hording and doesn't touch the swap much after starting.

    I would give the plotter more ram or run in parallel, but when I try to, the swap allocation gets worse and it goes slower (was getting anywhere from 4k-8k n/m). I lowered the number of hashes from 10 to 4 and that seemed to help quite a bit. Any clue what's going on here and how to avoid the gobbling?



  • @doiron I had memory leaks with java in win7. Since I am on win8.1, all is good.
    I think @Blago or @luxe can confirm, that there are problems with win7 and memory leaks.



  • omg win 8 i remember the start menu it was a pizza topping.



  • This post is deleted!


  • @haitch released a new version of gpuplotgenaerator, that when run as admin totally skips the slow build the file phase. Kill you plot and grab the new version and restart.

    my admin starting not working, where is mistake on my side? thanks for help .. where i can find full version 4.1.1 with all things in folder: cos on official page isnt full version gpuplotter? why missing .dll?



  • hi.. i was wondering if i have wrong setting in my gpu plotter?
    i only got 25k nonces/min
    with settings
    1 0 5120 64 7168

    i have rx 580 sapphire nitro + 8gb
    8gb ddr4 Ram

    and how long wound it take to plot 4tb drives in direct mode? Seagate/WD
    coz when i plot with buffered i finished it with 12 hrs.



  • @xmagmax First I must say I'm not an expert, second different PC would have diffrent setting depend on devices it have.

    Now that been said, to me your setting is a bit odd. Youe first value, which is 1, is the platform number that start from 0, 1 ,2 and so on. Normally it should be 0 because we only have 1 platform, at least mine is. The second value is the open GL device number, which also start from 0, 1 ,2 and so on. Open GL device would include all the CPU and GPU you have in your system, depend on the machine. You have to use bat file with "gpuPlotGenerator setup" command to check and decide which device you're going to use. gpuPlotGenerator setup command also tell you the rest value, but bare in mine these value are the potential max value your machine can handle. If, when plot and gpuPlotGenerator crash, you have to reduce these value (by haft).

    In my case, I use RX480 8GB VRAM to plot. My setting values are 0 0 8096 32 4096 (my GPU is devidce 0, and my PC has 16 GB of RAM). I was able to plot 10TB Seagate int.HDD SATA3 in around 30Hrs, 8TB WD ext.HDD USB3 in around 26hrs, all in direct mode. But 8TB Seagate Backup plus HUB ext.HDD USB3 is an odd ball for me. Even with same setting, it took me over 5days to finish, don't know why.

    So what I do to speed things up and reduce the chance of PC crash before finish plotting is to split in to smaller plot. I plot a 1GB plot onto a 1GB SSD then copy to the actual mining HDD, one at the time until finish the whole HDD.