GPU plot generator v4.1.1 (Win/Linux)



  • Thanks for the tool. It was hard to find an good Setup for the device.txt for my nvidea GTX 770, but now it works at least with ~8000 nones/min.
    Anyway I was wondering what this part of the README means:
    For Nvidia owners: OpenCL implementation is under-efficient on some NVidia cards. Try to tweak your device parameters. If there is no significant improvements, you'll need a CUDA version of this program.

    Are my 8000 nones/min are under-efficient and if so, how could I get the CUDA version of this program?



  • @luxe Do you know about that CUDA Version? I'm with a NVidia Geforce 820M and until now i couldn't plot with that gpuPlot generator... So i've been making my plots on the wplotgenerator and could use some speed xDD


  • admin

    no sry, not heard of a cuda version yet, openCL support is build on cuda i guess.



  • @luxe Re: "The bottleneck will be your hdd write speed, not the gpu ... but you can plot to multiple drives at once.R9 280x is like ~90000 nonce per minute". With the multiple drives option are the drives plotted in series or in parallel?


  • admin

    @iKnow0 They're plotted in parallel.



  • can i even plot with my gtx 980ti? ive tried it so many times now lol



  • @KeenHero 980ti is still a decent card, why wouldn't you be able to plot with it?



  • I use my R9 270x for ploting so your 980ti should be golden 😛



  • idont know i get error -5 everytime cant load kernel



  • [ERROR][-5][CL_OUT_OF_RESOURCES] Error in step2 kernel launch



  • @KeenHero Try lowering the last number in your devices.txt file.



  • recomended settings are "1 0 6144 768 8192" is this correct for the 980ti?



  • @KeenHero If they are the values setted by the GPUplotter setup yes, of course they are the recommended settings, but your gpu seems to run out of resources (maybe because it has to compute all your os and other programs graphics): a solution could be lowering the hashesNumber (the last number, values must be between 1 and 8192, higher number=better performaces, check the readme file)...



  • @vadirthedark I suggest you to write here to get more effective help about your GPU plotter issue 😉



  • ccminer,
    I tried the 'gpuPlotGenerator-bin-linux-x64-4.0.3' first, without success. Have done the first 4 steps listed below:

    Install the build-essential
    g++ packets
    Install OpenCL (available in the manufacturer SDKs)
    install the opencl headers ([apt-get install opencl-headers] on Ubuntu)

    The reminder is where I am in trouble. I do not understand this:

    Modify the [PLATFORM] variable to one of [32] or [64] depending on the target platform. Modify the [OPENCL_INCLUDE] and [OPENCL_LIB] variables of the Makefile to the correct path. Example:

    OPENCL_INCLUDE = /opt/AMDAPPSDK-2.9-1/include
    OPENCL_LIB = /opt/AMDAPPSDK-2.9-1/lib/x86_64

    Are the 'platform variables' listed and in which file should I look? Same question for 'OPenCL_...'.
    Thanks for any information you can give.



  • I hope that @luxe xould help @vadirthedark with this issue that interest me as well 🙂



  • Okay - from Readme file,

    "Modify the [PLATFORM] variable to one of [32] or [64] depending on the target platform. Modify the [OPENCL_INCLUDE] and [OPENCL_LIB] variables of the Makefile to the correct path."

    "OPENCL_INCLUDE = /opt/AMDAPPSDK-2.9-1/include"
    "OPENCL_LIB = /opt/AMDAPPSDK-2.9-1/lib/x86_64"

    I constructed a 'Makefile' from: https://github.com/bhamon/gpuPlotGenerator/blob/master/Makefile
    and made modifications as listed above. While looking at the OPENCL_ variables I went to 'opt' to see if 'AMDAPPSDK..' existed, it does not - looked in Package Manager in Ubuntu to see if packet is listed, it is not. I will try to install AMDAPPSDK... in /opt.

    First ? - Is it ok to use the 'Makefile'?
    Second ? - Is the /opt the one in root? Not sure how to set this up to get correct path from 'OPENCL_'.

    Thanks for any help available.



  • @vadirthedark Try to open an issue to github, the author of the script reply, at least he replied to me


  • admin

    Sry, i just used the win build ... never tried to compile on linux.



  • Hi, the gpu plotter gives me problems in direct mode at crashes 0.70 or 0.80%, in buffer mode do not. but slow more than it is. because it happens?