GPU plotter questions



  • maybe this was coded in foreign code pages



  • changed the config slightly a few times didnt work either


  • admin

    @ZapbuzZ double check your devices.txt - in the output earlier it was showing using platform 0 device 1, which is your AMD, but the plotter output is showing it using the nVidia, which is platform 1 device 0



  • same result windows error ony its the AMD chip that did it this time i didnt try admin rights i'll try that now



  • J:\gpuplot>gpuplotgenerator generate buffer j:\11481706595869336581_400000001_12021760_8192

    GPU plot generator v4.0.3

    Author: Cryo
    Bitcoin: 138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst: BURST-YA29-QCEW-QXC3-BKXDL

    Loading platforms...
    Loading devices...
    Loading devices configurations...
    Initializing generation devices...
    [0] Device: GeForce GT 730 (OpenCL 1.2 CUDA)
    [0] Device memory: 512MB
    [0] CPU memory: 512MB
    Initializing generation contexts...
    [0] Path: j:/11481706595869336581_400000001_12025856_8192
    [0] Nonces: 400000001 to 412025856 (2TB 888GB 0MB)
    [0] CPU memory: 2GB 0MB

    Devices number: 1
    Plots files number: 1
    Total nonces number: 12025856
    CPU memory: 2GB 512MB

    Generating nonces...
    0.00% (0/12025856 remaining nonces), 0.00 nonces/minutes, ETA: 22y 49w 0d 6h 56m 0s...
    [ERROR][-36][CL_INVALID_COMMAND_QUEUE] Error in step2 kernel finish

    got further this time


  • admin

    @ZapbuzZ Try changing the 8192 to 4096



  • didnt work

    Generating nonces...
    0.01% (1536/12025856 remaining nonces), 3177.93 nonces/minutes, ETA: 2d 15h 3m 41s...
    [ERROR][-36][CL_INVALID_COMMAND_QUEUE] Error in step2 kernel finish

    J:\gpuplot>gpuplotgenerator generate buffer j:\11481706595869336581_400000001_12021760_8192

    GPU plot generator v4.0.3

    Author: Cryo
    Bitcoin: 138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst: BURST-YA29-QCEW-QXC3-BKXDL

    Loading platforms...
    Loading devices...
    Loading devices configurations...
    Initializing generation devices...
    [0] Device: GeForce GT 730 (OpenCL 1.2 CUDA)
    [0] Device memory: 128MB
    [0] CPU memory: 128MB
    Initializing generation contexts...
    [0] Path: j:/11481706595869336581_400000001_12025856_8192
    [0] Nonces: 400000001 to 412025856 (2TB 888GB 0MB)
    [0] CPU memory: 2GB 0MB

    Devices number: 1
    Plots files number: 1
    Total nonces number: 12025856
    CPU memory: 2GB 128MB

    Generating nonces...
    0.02% (2048/12025856 remaining nonces), 3321.08 nonces/minutes, ETA: 2d 12h 20m 27s...
    [ERROR][-36][CL_INVALID_COMMAND_QUEUE] Error in step2 kernel finish



  • This post is deleted!

  • admin

    @ZapbuzZ If it's plotting, then yes, your screen is going to become very laggy due to the load on the GPU. You can use task manager to kicj the priority down to low, but it's still going to lag.



  • turns out 3120 nonces per minute for this graphics card as opposed to 3650 nonces per minute with the wplotgenerator. I can't expect much from a discreet nvidia anyhow lol thanks for your help guys using cpu lets it function without lagging one day i'll buy a big fat super dooper double slotter 🙂



  • now i got the correct way to start this plotter when i do have a bigger card 🙂



  • well, here i am trying again yay!
    found this new or old POC 2 version cryo made.
    It has a bug in direct plot generation that it only supports a linux EXT4 partiton for direct mode even in its windows port.
    So, since i have an installed read\write partition driver for ext4 i have a new problem:

    here is the command i executed followed with its error message

    C:\gpu>gpuplotgenerator generate direct E:\CRYO1\gpuplotgenerator generate direct F:\CRYO1\16884833744220149372_1111111111141632967_3576552_4096_2
    -------------------------
    GPU plot generator v4.2.2
    -------------------------
    Author:   Cryo
    Bitcoin:  138gMBhCrNkbaiTCmUhP9HLU9xwn5QKZgD
    Burst:    BURST-YA29-QCEW-QXC3-BKXDL
    ----
    Loading platforms...
    Loading devices...
    Loading devices configurations...
    Initializing generation devices...
        [0] Device: Bonaire (OpenCL 1.2 AMD-APP (2906.8))
        [0] Device memory: 512MB
        [0] CPU memory: 512MB
    Initializing generation contexts...
    
    [ERROR] Invalid file name
    
    C:\gpu>
    

    So did i execute it incorrectly? because I don't wanna stuff around with an optimisation tool (if theres one)


  • admin

    @zapbuzz If the _2 wasn't at the end of the filename, it would be a valid PoC1 file, but it's definitely not PoC2

    Use Engraver instead.

    https://github.com/PoC-Consortium/engraver



  • ok cool thanks @haitch @cryo please fix your miner 🙂



  • i actually got it to work but it was slow at writing plots.