XPlotter for optimized plots (CPU)



  • @Blago sorry i think the idea that we can plot and optimize at once is perfect but it needs a litle debuging i guess.

    but keep up doing the good work i apreciate all of your input into this.

    i wait for the update and try it again......



  • Yeah, @Blago we appreciate it! Don't want to seem rude or anything with all the questions. Personally, I'm super excited to see anything developing in this direction. Please let us know if we can contribute in a more productive manner.



  • @Rendavu @k-coins
    Thanks! I'd found a bug... forgot add start_nonce while generating nonces.
    v0.6 works fine ONLY for "-sn 0"
    (and all my tests was with "-sn 0")



  • @Blago said in XPlotter for optimized plots (CPU):

    @Rendavu @k-coins
    Thanks! I'd found a bug... forgot add start_nonce while generating nonces.
    v0.6 works fine ONLY for "-sn 0"
    (and all my tests was with "-sn 0")

    v0.7 on the works, i hope its done when the 5TB arrived.



  • @Blago well i just try to make a new plot 6 hours ago 500 GB with your xplotter 😞 LOL

    0_1482785481867_xploter.PNG

    The first 2 plots i just maked with wplotgenerator :

    0_1482785589441_Knipsel.PNG

    doesn't overlap the other plots i maked

    0_1482787618845_calculate.PNG

    So from your perspective do you think this is going to work or should i just push the exit buton 😉



  • https://github.com/Blagodarenko/XPlotter/releases/tag/v0.7
    bug fixed.
    tested after creation:

    XPlotter.exe -id 17930413153828766298 -sn 300000000 -n 0 -t 6 -path O:\plots
    


  • @Rendavu sorry, delete plot which created by Xplotter v0.6



  • Let's give it a go - starting .75 Tb now



  • @Blago said in XPlotter for optimized plots (CPU):

    https://github.com/Blagodarenko/XPlotter/releases/tag/v0.7
    bug fixed.
    tested after creation:

    XPlotter.exe -id 17930413153828766298 -sn 300000000 -n 0 -t 6 -path O:\plots
    

    giving it a try, deleted one 250GB plot



  • @Blago i replaced the v0.6 in the burst client version for windows 0.3.8 RC3 to v0.7 and i try to plot 250 gb 😉 hope for the best



  • @Blago thank you, thank you ......thousand times!

    250 gb plotted works like a charm with xplotter v0.7 perfect great devolpment for plotting

    chapeau !

    i do a test again now with 500gb ........



  • @Blago New 750 Gb plotted successfully with XPlotter v0.7 and now mining with no errors! Very nice work my friend and thank you so much for your work on this.

    Starting xplotter on a 5 Tb drive now 🙂



  • @k.coins How long did it take? can you share your specifications please?



  • @gpedro Not exactly sure how long it took. Less than 9 hrs because I left it on over night and had to remotely check on things later in the morning. The first few scoops are slow, then everything picks up after about 1% (if I remember correctly). Seemed faster than wplot but I have no data to support that.

    Here is the script for the run.bat (included in v0.7.zip, right click to edit) I used for the 750 Gb plot:

    XPlotter_avx.exe -id <numerical account ID> -sn 100000001 -n 3072000 -t 4 -path C:\Burst\plots
    pause

    (the pause here just keeps the screen open so you can check for errors after it's done)

    So... 3072000 nonces (starting at 100000001) gave me 750 Gb and I had 4 cores running the plot. After you get that saved, just run the batch file and it should start doin its thing.

    I just started a plot using the n- 0 parameter to see how it fills this 5 Tb (4.5 Tb really...), I can post an update on the progress later if anyone is interested.

    Also, let me know if you have any more questions or if the above wasn't clear. I'm still pretty new at this but might be able to help.

    -K



  • @k.coins Yeah thanks for the info and try to let me know about that update later please... Only questions i have is how much ram do you have? and if you know how was your RAM usage during plotting?



  • @gpedro I have 8 Gb of RAM on the machine I'm plotting with. However, Xplotter reported this at the beginning of the plotting:

    Uses 2048 Mb of 4943 Mb free RAM
    Allocating memory for nonces... OK
    [0%] Generating nonces from 900000001 to 900004097
    [0%] Generating nonces from 900004097 to 900008193
    CPU: 8192 nonces done
    HDD: Writing scoops: 0.63%

    So it looks like it was using less than half of what is available, which it reads as only ~5 Gb. I actually think Blago has it adjust this to automatically change based on what you have available (i.e. if you available RAM decreases, then your nonces/min will also decrease). Also, the system resources used seem to change after about 1% but I'll have to update you on that when this plots gets there.

    -K



  • @k.coins Cool thanks for the detailed information mate 😉



  • 500 gb done without errors i use the burst windows client build in xplotter so you don't have to count evry thing ....

    it works verry well .....

    15 tb to go lets plot 🙂



  • just finished plotting 232GB (950272 nonces) in 10491 seconds
    0_1482875325936_xplot4.PNG

    plotting while mining burst and nicehash
    0_1482875407577_xplot3.PNG

    XPlotter_avx.exe -id <account> -sn 4606760 -n 950272 -t 4 -path E:\ -mem 8g
    


  • @zyzzyva said in XPlotter for optimized plots (CPU):

    I've plotted two different 1TB drives with XPlotter so far, on two different Win7 64-bit systems, and one was good and the other gave deadline errors. One notable thing was that the bad plot was generated by the SSE4 executable (on an older system) and the good plot was generated by the AVX2 executable (on a newer system). Which versions are the rest of you using?

    Yes I think their could be an issue with sse2 and sse4 code path. However in blago defense it might be the CPU. My e5800 was what I used. Later I found plots made with avx2 were error free. Would mean as an older CPU wears out unnoticed to a word file it might be seen in a plot file