burstcoin-jminer v0.5.3 - GPU assisted PoC-Miner (All Platforms)



  • Ok I heard about this J-Miner and I do have a Gpu so, that leads me to ask myself "why am I using the Cpu-Miner"? Maybe because this is what I heard to use when first learning. I heard that the 'Blago' Cpu-Miner was the best. But I would like to try out J-Miner as I do have a Gpu. I have a Nivida 1080, should this work fine and is it as easy to set-up as the Blago?

    This is what made me want to try out the J-Miner - "GPU-MINER "J-Miner' > sCANS faster than a CPU-miner WHICH gives you an advantage to report to the 'pool' quicker". I read this somewhere here I believe, can't remember.

    So, is 4.6 the latest release and do we really need to download the CL-Driver - http://jocl.org/ and of course the latest Java, correct?
    Thx y0u!



  • @tradz GPU jminer works faster then CPU miner



  • @Blago Thx f0r the response but do you think you 0r anyone reading this with the knowledge, can answer my questions above. Starting with "is it as easy to set-up as Blago"?

    I guess instructions will be given inside the downloaded file, correct? And is 4.6 the lastest release?
    Thx



  • @tradz

    burstcoin-jminer-0.4.6-SNAPSHOT de-luxe released this 2 days ago. https://github.com/de-luxe/burstcoin-jminer/releases

    also it's contain good readme: https://github.com/de-luxe/burstcoin-jminer

    1. edit 'jminer.properties' with text editor to configure miner
    2. ensure java8 (64bit) and openCL driver/sdk is installed
    3. execute 'java -jar -d64 -XX:+UseG1GC burstcoin-jminer-0.4.x-RELEASE.jar' or run the .bat/.sh file
      '-d64' to ensure 64bit java (remove for 32bit) '-XX:+UseG1GC' to free memory after round finished.
      The miner is configured in a text-file named 'jminer.properties'. This file has to be in the miner directory (same folder as '*.jar' file)
    devPool=true
    plotPaths=D:/,C:/,E:/plots,F:/plots
    numericAccountId=<YOUR NUMERIC ACCOUNT ID>
    poolServer=http://pool.com:port
    

  • admin

    Thanks @Blago for helping out, while i was sleeping 🙂

    @tradz Just give it a try, both miners have their strenghts ... feel free to ask if you have a issue.
    jocl.org is just the java lib used by jminer, it is not the openCL driver itself, but on that page they link to the drivers of different manufacturers.

    OpenCL support is included in the latest NVIDIA GPU drivers, available at www.nvidia.com/drivers
    source: https://developer.nvidia.com/opencl
    So you may not need to install additional software to use OpenCl.



  • @Blago I thank you as well Blago! This was or is very helpful. Now I have a better understanding 😉 Blagone!!!
    I will report back here if I run into issues...



  • @luxe Nice to be writing with the MAN! Thank you as well for responding to my needs and in a timely [email protected] So, you think I should try to do things without downloading drivers, as you mentioned it's already included in my system?


  • admin

    @tradz Trying does not hurt 😛 If you start the miner and drivers are missing, the miner will tell you ....



  • @luxe Right! lol I decided to switch to the J-Miner come time the 30th a couple days before the next month starts so that I can start a fresh new month with better results. Blago is doing it's job for now, I can't complain!



  • @luxe Awesome! Thank you luxe!
    Using memory more than low. So I can load plot data from all HDDs at once!



  • Hi!
    I just bought a new pc and now jminer won't work.
    Here is the report from bat file

    F:\BURST bilgileri\burstcoin-jminer-0.4.5-RELEASE>java -jar -d64 -XX:+UseG1GC burstcoin-jminer-0.4.5-RELEASE.jar
    16:54:08.341 [main] INFO burstcoin.jminer.JMinerApplication - Starting the engines ... please wait!
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    #  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ff9f37270cd, pid=12204, tid=0x000000000000312c
    #
    # JRE version: Java(TM) SE Runtime Environment (8.0_121-b13) (build 1.8.0_121-b13)
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.121-b13 mixed mode windows-amd64 compressed oops)
    # Problematic frame:
    # C  [nvopencl.dll+0x3870cd]
    #
    # Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
    #
    # An error report file with more information is saved as:
    # F:\BURST bilgileri\burstcoin-jminer-0.4.5-RELEASE\hs_err_pid12204.log
    #
    # If you would like to submit a bug report, please visit:
    #   http://bugreport.java.com/bugreport/crash.jsp
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    #
    

    and I'm uploading the log file here

    Thank's for helping!



  • @umutusu said in burstcoin-jminer v0.4.6 - GPU assisted PoC-Miner (All Platforms):

    [nvopencl.dll+0x3870cd]

    Its openCL error, I downgraded nvidia driver and it worked with me. Maybe @luxe can be of more help here



  • @umutusu
    log file unavable.
    new pc with the same GPU or new?


  • admin

    @rnahlawi current jminer version uses latest jocl.org lib for openCL, thats all i can do/say ... glad you got it running ... jminer will be updated as soon as new version of jocl.org is available.

    @umutusu sry currenly have no concrete idea ... please try to google for

    EXCEPTION_ACCESS_VIOLATION (0xc0000005)
    

    i found some explanations but nothing concrete.


  • admin

    burstcoin-jminer-0.4.7-SNAPSHOT

    Download:

    https://github.com/de-luxe/burstcoin-jminer/releases

    Updates:

    • prevent reading optimized plotfiles in too much parts, if no useful number can be calculated due chunkPartNonces setting.

    Details:

    A optimized plotfile is handled in multiple parts by jminer, the calculation of the number of parts could lead to very high number due not perfect algo (i have to think about). Very high number of parts causes a drive/miner to be slow as hell.
    As quick fix i added a fallback that takes 8 parts if number of parts is bigger than 100.

    Edit: I run into the above issue after plotting with Xplotter auto all remaining space of a drive ... what leads to staggersize i never had before, so if someone had a slowed down jminer after plotting in the same way, check new version.
    Just to be clear, there is no issue with Xplotter, it is just awesome.



  • @Blago: https://www.sendspace.com/file/p39ll8 here it is
    everything new (msi gtx 1080)

    @luxe: I tried with stable version 0.4.5 and snapshot 0.4.6. i'll try with snapshot 0.4.7 and also take a look at for that

    EXCEPTION_ACCESS_VIOLATION (0xc0000005)
    

    @rnahlawi : i'l try that.



  • @Blago
    did you see the log file?
    @luxe
    with 0.4.7 it's the same error.
    And I can't seem to find any comprehensible explanation (at last I don't understand) for

    EXCEPTION_ACCESS_VIOLATION (0xc0000005)
    

    I even install visual studio and Cuda SDK (apart from Nvidia driver which normally contains OpenCL driver)
    @rnahlawi which version of Nvidia driver is you currently use? I searched for

    [nvopencl.dll+0x3870cd]
    

    but I don't understand that either.


  • admin

    @umutusu Sorry the log tells me nothing, i can only suggest this ... check if gpuPlotGenerator works for you:
    https://github.com/bhamon/gpuPlotGenerator/releases
    https://github.com/bhamon/gpuPlotGenerator#setup-1
    That would indicate that openCl drivers are fine. And it is only a jminer issue
    (i do noit think so)
    If gpuPlotGenerator also does not run, you should try to deinstall all gpu drivers and stuff completely (not sure with nvidea, for amd there is a tool to cleanup). restart your system and reinstall lastest nvidea driver only (should include openCL).



  • @luxe I created my plots yesterday with XPlotter to have optimized plots.I really don't want to wait again 36hours 🙂
    I downgraded nvidia drivers to previous version and I have no more this issue but now I have CL_OUT_OF_RESOURCES.
    I think the latest nvidia drivers have a problem or it's a opencl 1.2 issue with gtx 1080.
    Do you know how to resolve this CL_OUT_OF_RESOURCES issue?
    Thank you again


  • admin

    @umutusu Ok, you got me wrong ... i didn't want you to re-plot ... just to check if it works, as it is also openCL based. But if openCl context starts up now, please provide a image of jminer log ... are you sure you configured the platformId/deviceId correctly? is your gpu marked(*) on jminer startup?

    List of system openCL platforms and devices (* = used for mining)
    
     * PLATFORM-[1] AMD Accelerated Parallel Processing - (OpenCL 2.0 AMD-APP (2117.14))
     *   DEVICE-[0] Ellesmere (8GB) - Advanced Micro Devices, Inc. (OpenCL 2.0 AMD-APP (2117.14) | '2117.14 (VM)')
     *          [0] work group size: '256', computing units: '36', available 'true'
         DEVICE-[1] Intel(R) Core(TM) i7-4930K CPU @ 3.40GHz (68GB) - GenuineIntel (OpenCL 1.2 AMD-APP (2117.14) | '2117.14 (sse2,avx)')
                [1] work group size: '1024', computing units: '12', available 'true'
    
    (*) openCL context successfully started! (platformId: 1, deviceId: 0)